5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Internetルーティング講座

1 :nobody:2001/07/19(木) 23:22 ID:???
お料理好きのnobodyです。

ルーティング、特に大規模IGPだとか、BGPの綱引きに興味のある人向け
のスレです。

まずは、以下の資料を読んで勉強してね。

□大規模ネットワークにおける経路制御技術
http://www.nic.ad.jp/jp/materials/iw/1999/proceedings/i/C18.lzh

□BGP4 -プロトコルの概要と運用-
http://www.nic.ad.jp/iw98/presentations/C14.pdf

2 :Five:2001/07/19(木) 23:40 ID:???
勉強させる啓蒙なのか、勉強していない厨房職人にも
何でも答えるためのスレなのかよくわかりませんが。
せいぜい頑張ってください。

3 :nobody:2001/07/20(金) 00:14 ID:???
>2
前者ですね。Zebraスレで、Cisco本とかが紹介されていましたけど、職業人
じゃない人が読むのはつらいのではないかと。

4 :名無しさん@1周年:2001/07/20(金) 00:25 ID:Q2ruSt9Y
network やっている人はこのスレで勉強するのが重要。

社内LAN管理者もBGPについてはきっちりおさえておくべき。
理解して、人に説明できるようにすること。

5 :nobody:2001/07/20(金) 00:51 ID:???
ちなみに、私はBGPの運用やっているわけじゃないし、CiscoとJuniper以外は
よくわからんので、製品依存のネタが出たらそこんところ、みなさんのフォローを。

6 :nobody:2001/07/20(金) 00:52 ID:???
>4
マルチホームやるときにBGPの知識がいるようになるかもしれへんからねえ。

7 :ななし:2001/07/20(金) 05:01 ID:???
>>6
をいをい、マルチホームしているところにいちいち AS number 割り振っていら
れないって。普通は Linux の iproute2 で十分でしょ。

8 :Name Not Found:2001/07/20(金) 05:27 ID:???

地方のしょぼい中小企業だとYAMAHA様々だよ。
http://www.rtpro.yamaha.co.jp/RT/docs/multi-homing.html

9 :cinq:2001/07/20(金) 09:36 ID:???
2はおそらく偽者だな

BGP/MPLS VPNを管理してます
...が手を出してはならんぞ皆の衆

10 :nobody:2001/07/20(金) 12:31 ID:???
>7

PAじゃなくて、PIなアドレス持っている所で、独自AS取る場合にはBGP必須
だけど、プライベートASでマルチホームやっている所もありますよ。

11 ::2001/07/20(金) 13:00 ID:???
昨日、CiscoでOSPFの設定しててはまったんだけど、
VLSMのスタティック経路を再配布するときって、
reditri sta
の後に"subnet"をつけなきゃいけないことを初めて知った。
VLSMは社内では初めて使ったんだけど、
これってもしかして常識だったの?
ciscoのリファレンスにはそんなこと書いて無かったよ。
1時間悩んだ。

12 :11はアホ:2001/07/20(金) 13:53 ID:???
>>11 はDQN
>ciscoのリファレンスにはそんなこと書いて無かったよ
ハァ、おめーがみたリファレンスってどこじゃヴォケ
よくリファレンスみろ!!!
どーせCCNPとったくらいでよろこんでるDQNだろ
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/ind_r/1rfindp2.htm#xtocid37890
http://www.cisco.com/univercd/cc/td/doc/product/software/index.htm

redistribute (IP)
To redistribute routes from one routing domain into another routing domain, use the redistribute command in router configuration mode.
To disable redistribution, use the no form of this command.

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}]
[tag tag-value] [route-map map-tag] [weight number-value] [subnets]

no redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}]
[tag tag-value] [route-map map-tag] [weight number-value] [subnets]


Syntax Description protocol
Source protocol from which routes are being redistributed. It can be one of the following keywords: bgp, connected, egp, igrp, isis, ospf, static [ip], or rip.

The static [ip] keyword is used to redistribute IP static routes. The optional ip keyword is used when redistributing into the Intermediate System-to-Intermediate System (IS-IS) protocol.

The connected keyword refers to routes that are established automatically by virtue of having enabled IP on an interface.
For routing protocols such as Open Shortest Path First (OSPF) and IS-IS, these routes will be redistributed as external to the autonomous system.

13 :喜ぶ名無し:2001/07/20(金) 14:47 ID:???
>>8

そのとーりです…イタタ
Ciscoなんであんなに高いんだよぉ
LinuxBOX使って何とかしたいのが現状
ってなことで…勉強しなければ
あ。今日は休日じゃないかぁぁぁぁ

14 :nobody:2001/07/20(金) 15:02 ID:???
あと、OSPFにredistするときはE1かE2か考えてやって下さいね

15 :nobody:2001/07/20(金) 15:53 ID:UjqXIL.w
>E1かE2か
E1とは?

16 :nobody(1):2001/07/20(金) 16:34 ID:???
>15
1の「大規模ネットワーク経路制御技術」は読んでいただけましたでしょうか?

25pに解説があります。

17 :ななし:2001/07/20(金) 17:15 ID:???
>>15

そこまで聞いては厨房扱いされてしまいかねません
基礎本やgoogleでわからなかったら
ここで聞くほうがよろしいかと…

ってなことでがんばりましょう〜

18 : :2001/07/20(金) 18:04 ID:???
>>15
e1とかe2がわからんようでは、ospfやredistもわからんだろ
だったらe1の意味がわかったところで無意味だろ

19 :11:2001/07/20(金) 18:18 ID:???
>>12
罵倒しつつも資料をくれる>>12に感謝
こうやってたたかれつつ、スキルアップしてきたい

20 :七資産:2001/07/20(金) 18:52 ID:???
とりあえず>>19はまともなSEのようだ
世の中には>>12のしてくれたことの意味がわからんDQNが多すぎる

やさしく何でも教えてくれるような神様はこの業界にはおらんのよ

21 :喜ぶ名無し:2001/07/20(金) 19:23 ID:???
>>20

やはり、それは自分の手の内ということなのでしょうか?
代々先輩から引き継がれる極意なのでしょうか?
それともシスコのやりかた?(いみわかんねーよ)

22 :nobody(1):2001/07/20(金) 19:35 ID:p5DaTaQs
>19
>21

本当の意味での参考書なんてないからねえ。この業界は。
新人君教育する際に困るので、InternetWeekやJanogの資料をつかわさせて
頂いております。

1で書いた資料2つは、最初見つけたときに結構驚いた資料です。ISPやSI
ベンダなんかの奥義、というと大げさやけど、こういう情報を親切丁寧に
書いてくれている本はあまりないので。

23 :21:2001/07/20(金) 21:06 ID:???
ありがたやありがたや
(-人-) ナムナム

24 : :2001/07/20(金) 21:33 ID:???
罵倒するぐらいなら教えなきゃいい。
教えるんなら気持ちよく惜しげもなく教えればいい。
結局「教えてやった」っていう充足感を味わいたいだけ。
しょせんはマスターベーション。
感謝する必要なんかねーよ。

25 :a:2001/07/20(金) 21:48 ID:???
>>24
惜しげも無く教えたら、そいつはしつこく質問してきやがるでしょ

>>1が最初に、ここは啓蒙するスレだっていってるじゃん
>>12はとりあえず説教して、資料だけ教えてやる、後は自分で調べれ
っていうスタンスを示したんだろ
>>1の言ってる趣旨の通りにやっただけ

それが気に入らないんだったら、別のスレ逝け

26 :SOI:2001/07/21(土) 03:20 ID:05wvKFyE
>>1
http://www.soi.wide.ad.jp/
にそれのビデオあるよー
IW2000も友近さん前村さんで
「大規模ネットワークにおける経路制御設計」というタイトルです。

27 :ななし:2001/07/21(土) 13:32 ID:???
前村昌紀氏監修の「インターネットルーティング」(翔泳社)は
サブタイトルが経路制御技術の現在と未来となっていて、いい感じ。
未来は去年の夏現在なので、MPLSに関しては中途半端になってるけど。

体系的に勉強するのは難しいねー

28 :ななし:2001/07/21(土) 20:22 ID:???
>>27
とりあえず、基礎を固める意味でダイクストラ木とかの
大学の講義でやるネットワーク論から勉強していくのも
いいかと。

あと、実質的な前スレの Zebra スレでもまだ出ていて
来ていない参考書としては「次世代 TCP/IP 技術解説」
の8〜10章っていうのがありますね。

29 :偽root:2001/07/23(月) 12:19 ID:???
あの〜ぉ
IXとかを作るとして必要なのはそれらプロトコルを扱えるルーター
だけなのでしょうか?
FreeUNIXにNIC二枚挿しでZebraで何とかしようと考えているのですが…
安心できる設備とはどの程度のものを購入すれば良いのでしょうか?

30 :nanasisan:2001/07/23(月) 15:26 ID:???
>>29
基本的にはそれで OK。昔の NSPIXP なんかも WS で routing
させていたところもあったはずだし。

31 :nanasisan:2001/07/23(月) 15:39 ID:???
そいえば、itojun さんが NetBSD に multipath を
support させたようですね。

32 :名指しさん:2001/07/23(月) 16:36 ID:aC9TGyOU
>>29
IX作るの? それなら Hub置けばそれで完了!

33 :名指しさん:2001/07/23(月) 16:37 ID:aC9TGyOU
追加

アドレスもとってね

34 :29:2001/07/23(月) 16:56 ID:???
社内でやろうと思ったけど…
趣味の範囲を超えているので、どーせなら大きいこと考えてみました

たとえば栃木IXとか福島IXを作るとした場合
まずなにをすればいいの?
(書類とかそーいう細かいのは抜きとして)

JPIXから光ファイバーで宇都宮まで引いたとして
メディアコンバーターで光->ethにしてHubにつなぐだけ?

なんかRutingとかは?

35 :nanasisan:2001/07/23(月) 21:24 ID:???
IX っていうぐらいだから、複数の AS が接続していないと
だめでしょう。JPIX から線を引いてくるだけじゃなくて、
プロバイダからも線を引いてくる。

んで、BGP をしゃべれる router (PC UNIX + Zebra でも OK)
をつないで、AS number を振って…とかいう感じになる。

36 :sage:2001/07/23(月) 21:54 ID:???
厨房な質問で申し訳ないのですが、一つお願いします。

CiscoルータでOSPFのdistribute-listを書いて、
ConectedなRouteをフィルタするにはどうすればいいのでしょうか。
------------------------------------------
Conected 172.16.100.254/24
Conected 192.168.100.254/24
Static 10.100.100.0/24 via 172.16.100.1
!
router ospf 1
redistribute static
network 172.16.100.0 0.0.0.255 area 0.0.0.0
network 192.168.100.0 0.0.0.255 area 0.0.0.0
distribute-list 10 out
!
access-list 10 deny 172.16.100.0 0.0.0.255
access-list 10 permit any
-------------------------------------------
こんな感じに設定したのですが、172.16.100.0/24の経路を投げてしまいます。
フィルタをインターフェイス指定にすればよいかと思ったのですが、
インターフェイスを指定すると、
%interface not allowed with OUT for OSPF
といわれます。

どなたか、ヒントをいただけないでしょうか?

37 :29:2001/07/23(月) 22:03 ID:???
>>35
ありがとう!
なんとか掴めてきました

結局のところシスコも高いけど
線が一番高いね(NTTなんとかしてよー

38 :nobody(1):2001/07/23(月) 22:56 ID:???
>36

OSPF出し側のdistribute-listって効いたんだっけ?
なんか制限あったような。

39 :nobody(1):2001/07/23(月) 23:11 ID:???
>35
単なるL2スイッチじゃだめなの?

IXって、あくまでもISP同士がピアを張る所だって認識だけど....

40 :36:2001/07/24(火) 00:20 ID:???
>>38
OSPFの経路でも、Redistでも、Conectedの経路以外は問題なく効くんです
Conectedだけどうしてもフィルタできない
これができないと10台近い既存ルータスタティックをきらなきゃならないんです。

何か良い方法って無いですか?

41 :ななしさん:2001/07/24(火) 00:49 ID:uh8K5uhs
誰か、↓のシミュレータ使ってる人いる?
http://www.routersim.com/

42 :失礼します:2001/07/24(火) 02:41 ID:???
どなたか、下の調査にご協力いただけませんか。
ななひさんという方他ががんばっていらっしゃるようですが
あまりネットワークに強くないようなので・・・
ここはネットワークに強い方が多そうなので、sageつつ募集です。

W杯サイト2002japanworldcup.com、日本歴史教科書に抗議
http://kaba.2ch.net/test/read.cgi?bbs=news&key=995489005&ls=50

# 自分はななひさんでは無いです。念のため。

43 :名指しさん:2001/07/24(火) 17:06 ID:a03lKNGI
>>35
>>39
のいうとおり L2 SWだけでOK!
JPIXから線を引かなくてもTransit買わなくてもBGP知らなくてもルータなくても
IXはできます。

44 :37:2001/07/24(火) 17:11 ID:???
L2スイッチって…おいくらなのでしょうか?ボソッ

45 :(・∀・) :2001/07/24(火) 17:42 ID:XG/nkzGo
>>36
172.16.100.0 のRoutingをくらいたくないRouterのinでフィルタすれば(・∀・) イイ!!
>>38の云うとおりOSPFはdistribute-list outで制限デキナカターヨ

46 :nanasi:2001/07/24(火) 18:31 ID:???
>>43
なるほど。単なる線の集積所としての IX だとそうですね。

>>44
そこいらに転がっている ehternet のスイッチングハブでも
立派な L2 スイッチですから、¥3000ぐらいからあるかな?

VLAN 切れるような高級品でも¥2万ぐらい?

47 :36:2001/07/24(火) 22:58 ID:???
やっぱできないんですね、、、
実際はもっと複雑な構成になってて、
172.16.の不連続なVLSMがいくつかあって、
別のルータも172.16.の中の経路のいくつかを流してるんです
知っちゃいない経路と知っても良い経路が不連続になってるんです

どうせ同一セグメントのルータ全部に細かいフィルタ書かなきゃならないのなら、
潔くPassive(Listenはしなきゃならないんで)にしてスタティックをきることにします

でも、どうしてConectedだけフィルタできないんでしょう?
他は全部フィルタが効くのですが

やっぱ設計ミスですか?

48 :nobody(1):2001/07/24(火) 23:41 ID:???
>47

OSPFって、よく考えるとリンクステートですよね。ルータ間の接続状況を
交換していると(くわしくは>>1の資料を参照してね)。

で、コネクトな情報をフィルタするって、どうやればいいんでしょうか?
そのリンクステートを送信しないなら、ルータ間の接続がないのと同じでは
ないでしょうか?
#くわしくは調べてないよ、OSPFのoutフィルタは効かないと思い込んで
#いたから....

dist-listのinは、「データベースとして持つが、ルーティングテーブル
には載せない」という動作と思われ。実験してみればよくわかると思う。

汚いネットワークをどーにかせなあかんのは往々にしてあることです。あまり
に汚いネットワークにキレて、境界間をBGPで繋ごうかと思ったこともありま
したなあ....

49 :36:2001/07/25(水) 00:55 ID:???
>>48
いろいろありがとうございます

いい勉強にはなりましたが、
Ciscoマルチベンダーな世界でどっぷりEIGRPにつかりたい今日この頃です

50 :49:2001/07/25(水) 09:50 ID:???
間違い、シングルベンダーだ

しのう

51 :かなり名無しさん:2001/07/25(水) 10:10 ID:???
そかそか、L2か、勘違いしていました

あ、で。

192.168.0.xと192.168.1.xと192.168.2.xを共用ゲートウェイ
させるって場合にRoutingの技術が必要なのですよね

大勘違いでした

52 :名無しさんに接続中…:2001/07/25(水) 20:39 ID:???
相互に通信させたいだけなら、192,168.3.xも含まれちゃうけど192.168.0.0/22にするという方法も有るよ。

53 :49:2001/07/25(水) 23:59 ID:???
>>48
できました!
192.168.と172.16.でそれぞれ別のOSPFプロセスを動かしたらできました。

こんな感じです
---------------------------------------------
!
router ospf 1
netwaork 192.168.0.0 0.0.255.255 area 0.0.0.0
redistribute ospf 2
redistribute static subnet
distribute-list 10 out ospf 2
distribute-list 10 out static
!
router ospf 2
network 172.16.0.0 0.0.255.255 area 0.0.0.0
redistribute pspf 1
redistribute static subnet
!
access-list 10 deny 172.16.100.0 0.0.0.255
access-list 10 permit any

54 :nobody:2001/07/26(木) 22:06 ID:???
うーん。要するにConnectなアドレスがExtで見えるようになったということ
ですよね。これで本当に問題ないんですか?

あと、複数プロトコルの利用の際には、distanceを設定しておかないと、
ややこしい動作をするかも.....
#構成がよくわからんので何とも言えぬが...

55 :53:2001/07/26(木) 23:56 ID:???
すいません、もちろん書いてない設定はたくさんしてます。
そのあたりは抜かりない(はず)です

今のところ、一応正常稼動しています。

56 :名無しさん:2001/08/05(日) 01:03 ID:???
惜しいのでアゲ

57 :route-map:2001/08/05(日) 05:23 ID:???
redistribute static subnets route-map hogehoge にして、
route-map側で、match ip address 10 なりなんなり好きなだけ書けばいいのでは?

58 :ななし:2001/08/09(木) 15:35 ID:???
あげときます

59 :?:2001/08/09(木) 23:29 ID:???
>>57
話が理解できてないと思われ
connectしてる経路のフィルタの話だろ?
rouetmap以前にフィルタ自体がが効いてないのではないかと、、、

60 :nobody:2001/08/13(月) 00:50 ID:???
なんか落ちちゃってますねえ。

簡単な質問でも気軽に質問してもらってよいのですが、どうも最初に>1で出来
のいい資料を出しちゃったのがまずかったのかなあ。いかにも「タコは勉強し
てから来い」って言ってるようで。

>1を書いたちょっと後に、某所であの資料を印刷している光景に出くわした。
まさかココ見てたんじゃ....
#しかし、あのプレゼンの内容を売り物の本で読もうと思うと、学生なんか確実に破産ですね

61 :age:2001/08/13(月) 01:20 ID:???
nobody氏の嘆きに応えて一つ質問

Ciscoの2503(IOS12.1(7)でOSPFの経路フィルタが
コマンド投入直後は漏れていた。
いろいろやってもダメなので、結局リブートしたら
ちゃんとフィルタがかかったんだけど、
これってこのまま運用していいものなのかちょっと心配です。

だれかご意見をお願いします。

#Ciscoスレに逝けって感じかもしれませんが、一応ここで

62 : :2001/08/13(月) 12:52 ID:???
>>60
あんた自意識過剰だね。

63 :isp:01/09/30 05:16 ID:rvmhQULQ
顧客とのあいだは通常staticだと思いますが、
顧客に要求されたときはどこまで色々しても大丈夫でしょうかね?

もちろんdynamicにするとしてもacceptする経路はfilteringするなど以外で。

64 :nobody:01/09/30 12:49 ID:???
>63

間違ってもOSPFにしてはいけません(笑

通常は、BGPのみにして、ルートマップでがしがしにフィルタかけると思うの
ですが。当然、顧客にはプライベートASを渡して。ASパスフィルタもがしが
しにかけておかないと、非常に面倒なことになる可能性もある。

「色々」の意味がわからないのでこのへんの一般論で。

65 :ospf:01/09/30 19:19 ID:jdUb./kE
>>64
>>64
別ドメインのOSPFをするのは問題ないのでは?

もちろんその上でそちらのOSPFでもらった経路を
バックボーンOSPF側へそのまま垂れ流さなければいいだけ。

66 :名無しさん :01/09/30 19:27 ID:c1qYQbuw
>>63,64
別のASにしちゃえば何でも良いでしょ。

67 :nobody:01/09/30 20:24 ID:???
>65

そのとおりですね。失礼しました。

68 :マターリfoo:01/10/01 03:22 ID:DQoQxIfE
ひさびさにみたら
難しすぎてわかんねー話題ですね….
鬱出し脳

69 :anonymous@ eAc1Aaa137.tky.mesh.ad.jp:01/10/04 01:52 ID:JGxRk5DU
突然書き込みしてすいません。
いつも思うのですが、JPIXのMLに出ている「出国のピーター」さんっって
何者なのですか?あの、独特の日本語がまーべらすです。

某ISP、やたらPrefixの小さい経路を流さないで下さい。(フィルタで対処してるけど)

70 :名無しさん:01/10/04 02:35 ID:???
>>69
おもしろい方です。あやむら氏と仲がよろしいようで。
某所のchapter11騒ぎで去ってしまわれないかが怖いです...

71 :774:01/10/06 15:29 ID:XmIJCUhA
>>69,70
ピーターさんもう辞めてるよ。JPIXのMLにご本人が出してたでしょ。

ところで、69さん、どれくらいの大きさのprefix-filter書いてます?

72 :nobody:01/10/06 15:44 ID:???
Janog8でIIJの近藤さんいわく、なんか/31があったらしいね。
/31は実験だろうか?

73 :69:01/10/06 17:30 ID:???
>>71
うちは/25まで食べます。

>>72
/31ですか?まじでぇ?!?!?!
最近、/24のアドレスが/28で16に分割されて広告されているところ
があるんだけど、なにかの実験かな?

74 :mogu2:01/10/06 17:44 ID:???
>Prefix-filter
うちは/24まで食べてます。

日本でも大手さんだったらこいう情報Webで公開して欲しいかも

#golの社長さん射殺されたそうで、エクソダスは災難続きですね

75 :69:01/10/09 20:43 ID:???
>>70,71
ありがとうございます。お礼がおそくなってすんません。

あの心あたたまる日本語を読むことはもうできないのですね、、、、

76 :ななしさん:01/10/09 22:43 ID:???
翔泳社のインターネットルーティング入門(NTTコムの知近氏+池尻氏+小早川氏)

入門編なので、ほんとにビギナー向けだけどMPLSネタもあります。
姉妹書のTCP/IP入門も合わせて読むとよいかと。

77 :fshiansan:01/10/09 23:07 ID:???
CiscoPressのインターネットルーティングアーキテクチャも良い
2版がでてたので思わず買ってしまった。
思ったより親切なつくりで初心者でもいける。
(ネットワーク初心者じゃなくてBGP初心者ね)
良書だ

78 :名無しさん:01/10/23 16:29 ID:DHHqSRab
>>73,74
IXの受け入れ経路だけでなく、
トランジット側も同じなんですか?

>>75
NRIに結局行かれたんでしたっけ。

79 :名指しさん:01/10/23 16:46 ID:cKJq+c2Q
ぴーちゃんPS2でLinux

http://www.ixp.jp/

80 :anonymous@ adsl5116.ea.rim.or.jp:01/10/31 02:01 ID:???
age

81 : :01/12/29 16:56 ID:???
ハッカーの次なる標的はルータ
http://www.atmarkit.co.jp/news/200112/27/router.html

82 :nobody:02/01/02 00:35 ID:???
>74

完全にこのスレの存在忘れてたけど、IRRからそういう情報は推測できないかな。

IRRを実際にはどう使っているか、富山へ聞きに行こう...

83 :74:02/01/09 05:04 ID:???
>>82
IRR 〜Worldwide Status & Current Practice〜
これですね。まだ受け付けてるようなので上司に申請出してみます:)

しかし、今回の参加者リストの中に
Jeff Doyle Juniper Networks
なる名前発見!ホントに当人なんだろか?
CCIE本持っていってサインもらいたいかも :D

84 :nobody:02/01/17 13:53 ID:???
とりあえずここでアナウンス。

来週、富山で開催されるJanog9の締切りが迫ってきました。まだ申し込め
ますので、Jeff Doyleさんの生声を聞いてみたいという方は今直ぐ申し
込みを。
#通訳はありませんが

http://www.janog.gr.jp/meeting/janog9/index.html

85 :anonymous:02/03/03 07:43 ID:???
マルチキャストを使いたいのですが、
どのルーティングプロトコルがオススメでしょうか?

86 :名無しさん:02/03/03 12:31 ID:???
>>85
PIM

87 ::02/03/03 14:24 ID:???
>>86
その根拠は?

88 :名無しさん@お腹いっぱい。:02/05/19 23:53 ID:r0icwMOT
あげ

89 : :02/05/20 05:10 ID:4+o5CBbQ
>>81
ご飯中失礼するが、次なるじゃなくて最初のだとオモタ。
いや、オマエに言ってるんじゃなく書いた奴にナ。

Ciscoはいいルーターではないと思う人より(ぷ

90 :名無しさん@お腹いっぱい。:02/07/01 14:02 ID:ukR9zFpi
今月のOPEN・DESIGN誌はIPルーティング入門でしたね
だれか買った人いる?

91 :balance:02/08/11 18:56 ID:6QjWxEiW
OSPFということで、ここが内容的に近いスレですかね?(無理矢理ですが)
今頃知ったんですが、ダイクストラ教授が8月6日に亡くなったんですね。
ご冥福をお祈りします。

92 :nobody:02/08/12 00:08 ID:???
>91

ダイクストラアルゴリズムには、いろんなところでお世話になってますね

93 :?:02/10/25 16:57 ID:???
OSPFの外部経路の集約について質問させてください

全てOSPFが稼動している4拠点を結んでおり、
拠点間WANから各拠点のコアL3-SWまでをArea0、
各拠点のコアから下はそれぞれ別のAreaという設計になっています。

そのうち一つの拠点は、さらにその下にいくつかの集約可能な
EGRPとStaticのネットワークがWANでつながっており、
それぞれ別のルータからOSPFにRedistしています。
これらルータはABRになっているコアのL3-SWではなく、
別のL3-SWにつながっています。

最近、このRedist経路が多すぎることが問題になっているのですが、
これを集約するには、拠点のコアL3-SWか、
WANルータのつながっているL3-SWでプロセス分割するしかないのでしょうか?
プロセス分割以外に何かいい方法は無いでしょうか?

あと、プロセス分割する場合どちらで分割したほうはいいでしょうか?
外部経路が入ってくるぎりぎりのところで分割すべきか、
拠点内のプロセスを一つに統一するために、コアで分割すべきかで迷っています。

目的が外部経路の集約だけなら、外部経路をRedistしている
WANルータがつながっているL3-SWで分割すべきなのでしょうが、
将来的に各拠点も同じようにプロセス分割する可能性を考えると
コアで分割したほうがいいような気もします。


94 :nobody:02/10/27 09:22 ID:???
>93

詳しくみたわけではないので、個人的な感想ですが.....
外部経路の集約はプロセス分割しかないですね。OSPFはリンクステート形な
んで。で、Redist経路が多すぎるのは、何が問題なのでしょうか?

・各拠点のL3 SWの能力が心配
・管理上、やたら多くのprefixがあるとわけがわからない
・その他

とりあえず、L3スイッチの能力が心配だ、っていうことにしておきます。
その前に質問ですが、ISDNバックアップなんかやってないですよね?細かい
prefixがないとうまく迂回できませんので...

で、この場合ですが、やはりWANルータにつながっているL3 SWでプロセス
分割することをお勧めします。L3スイッチっていってるので、OSPFの処理
能力はそんなに高くないとおもいますので、エリア分割と経路集約・マル
チプロセスを1台でやるのは、よくないと思います。
#メモリの問題もありますし

他にも、その機械がどんな機械かよくわかりませんが、コアでやると管理
上見にくくなるんではないかなと。プロセス分割するノードでは、ルーテ
ィングテーブル自体は沢山prefixがあるのに、片側には集約経路を流して
もう片側にはそのまま流すわけで。
#このへんJuniperはわかりやすいんだよな

95 :?:02/10/27 15:35 ID:???
>>94
ありがとうございます。

主な理由は管理上の問題です。
"せっかく集約できるようにアドレス割り当ててるのに、集約できないんじゃ意味がない"
という指摘をうけまして、特に大量なWANリンクの経路が気に入らないようです。

能力的にはカタログスペックからは問題ないはずです。
現時点の負荷も目に余るものではないです。

バックアップ経路は全て単純な2重化構成で並列になってますんで、
バックアップ経路も集約した下位に入るので問題は無いです。

拠点のコアで集約しようと思ったのは、拠点ごとにコアから経路をもらって
経路を管理(というか唯単にコアと同じ経路持ってるだけ)してるノードがいるので、
拠点の経路は全Prefixを持っていた方がいいかなというのと、
Internalの経路はここで集約しているので、経路集約を一箇所でと思ったからです。

集約すると決まったからには、分割ポイントを決めて、設計書を出さなければければならないんですが、
正直どっちがいいって言うのは相当大規模な検証をしないと説得力のある説明ができないんです。
"コア-L3はトラフィック処理がメインの仕事だから、エッジルータのつながっているL3で分割”
というのが、押しが弱いような気がして、
"だったら拠点間WANルータで分割すれば?"
といわれたら、Area設計からやり直しに、、、、

正直なところ、元々はバリバリのマルチプロセスEIGRPだったのを紆余曲折の上
ようやく全てOSPFしていて、この外部経路は過去の遺産なんです。

いろいろ考えましたが、プロセス分割で能力問題が起きたときに、コアは簡単にリプレイスできないので、
ご指摘もいただいた通り、やっぱり提案は、エッジルータを収容しているL3で分割する案を推してみます。

ありがとうございました。

96 :nobody:02/10/27 20:03 ID:???
>95

をを、難しい状況だったんですね。

>正直なところ、元々はバリバリのマルチプロセスEIGRPだったのを紆余曲折の上
>ようやく全てOSPFしていて、この外部経路は過去の遺産なんです。
うわー、やりたくない仕事だなあ。お疲れ様でした。
ただ、こういう、コア以外の所ででっかいWANが繋がってしまう、というのは
広域LANやIP-VPNに移行中な時によくある話ですね。

97 :山崎渉:03/01/15 22:38 ID:???
(^^)

98 :anonymous@ PPPa72.e6.eacc.dti.ne.jp:03/03/05 00:06 ID:uZA3slVb
CiscoルータでIS-ISを動かすには、IOSのどのバージョンから稼動できるんでしょうか。

99 :nobody:03/03/05 00:17 ID:zBOjycbG
>98

IS-IS自体は相当前のバージョンからサポートしてるけど、
IS-ISのIPv6対応を言ってます?それともMPLS-TE用IS-ISですか?

100 :anonymous@ PPPa44.e6.eacc.dti.ne.jp:03/03/05 00:30 ID:JE8J3ZK/
>99
IPv6は考えておりません。普通の12.0(6)とかでも、router isis とか入れても
反応がないのですが。show isis routeとかもshow isis databaseとか
show clns... とかを試してみたいです。(早速のお返事ありがとうございます)

101 :sage:03/03/05 22:17 ID:???
>>1002500 以上のルータでしか動かんよ

102 :_:03/03/05 22:18 ID:???
単に(使えない機種and/or使えないeFature Set)使っているんだろ。
3600シリーズなら、IS-ISは11.3あたりから使えるよ。

103 :anonymous@ planexfw.planex.co.jp:03/04/05 06:56 ID:???
すんません、RIPの事聞いていいっすか?
NATルータはLAN側に"default route(default-information、0.0.0.0/0.0.0.0のこと)
を出すものなんでしょうか?

手元に2種類のNATルータがありますが、出すやつと出さないやつがあります。
出すか出さないか設定できるのが一番ですが、設定できない仕様の場合、
どっちが正しいもんなんでしょうか?(メーカーに文句言えるし)

あと、出すやつは出すやつでいいんですが、Metricが絶対に2なんですよ。
default routeのMetricが設定できないのもあまり良いようには思えないんですが。


104 :山崎渉:03/04/17 12:23 ID:???
(^^)

105 :あぼーん:あぼーん
あぼーん

106 : :03/05/01 14:54 ID:???
>>103
かなりワラタ

面白かったので答えときます。

>手元に2種類のNATルータがありますが、出すやつと出さないやつがあります。
>出すか出さないか設定できるのが一番ですが、設定できない仕様の場合、
>どっちが正しいもんなんでしょうか?(メーカーに文句言えるし)

"Windows95はRIPをListtenできないんですがこれはエンドノードノードして正しい実装ですか"
というのと同じぐらい愚問

まあ、一昔前の実装ならむしろRIP吐く方が正しいとも言えるかな


>あと、出すやつは出すやつでいいんですが、Metricが絶対に2なんですよ。
>default routeのMetricが設定できないのもあまり良いようには思えないんですが。

RIPのメトリックはHop数だから
それをおかしいというならRIPの実装そのものがおかしいということになる
まあ、実際におかしい実装なわけだが

107 :あぼーん:あぼーん
あぼーん

108 :あぼーん:あぼーん
あぼーん

109 :あぼーん:あぼーん
あぼーん

110 :ぼるじょあ ◆yBEncckFOU :03/08/02 05:19 ID:???
     ∧_∧  ∧_∧
ピュ.ー (  ・3・) (  ^^ ) <これからも僕たちを応援して下さいね(^^)。
  =〔~∪ ̄ ̄ ̄∪ ̄ ̄〕
  = ◎――――――◎                      山崎渉&ぼるじょあ

111 : :03/08/15 14:01 ID:???
すいません、質問させてください

E-BGPのOutのroute-mapでno-export属性をつけたルートは
対向のASには流れて、対抗のASから外には出ないという形になるのでしょうか?
それとも対向のASにも流れないのでしょうか?


112 :あぼーん:あぼーん
あぼーん

113 : :03/08/27 13:41 ID:???


114 :_:03/08/28 22:11 ID:???
なんつーか、こういう記事も必要な人がいるんじゃないかなぁ、
とか思ったので貼っておきます。

[連載]IPルーティング入門
ttp://www.atmarkit.co.jp/fnetwork/rensai/iprt01/iprt01.html


115 :__:03/09/10 17:25 ID:???
特定のpeer先とロードバランスをしたいのです。
2本のラインは別のルータに収容されてます。

BGPで受けた経路ををOSPFにredistして、
ロードバランスを行いたいのですが実績とか
TIPSとかあったら教えてください。

116 :nobody:03/09/10 22:07 ID:???
>BGPで受けた経路ををOSPFにredistして、

うーん。経路数が十分少なければこのアプローチも可能だと思うけど、
大規模な環境だと普通はiBGPでlocal prefかなんかで振り分けませんか?

iBGP multi-pathってのもありだと思うけど。

117 :nobody:03/09/10 22:07 ID:???
>111

対向のASの外には出ないようになるはずです。

118 :__:03/09/10 23:33 ID:???
>>116
iBGPでLocal_Prefで分散しましたっけ?
iBGP MultiPathだと同一収容ルータからのトラフィックは
分散しない気がするのですが。


119 :?:03/09/12 01:49 ID:???
>>118
Border2台からOSPFに等価でDefaultを流して
Border間でiBGPを張るんじゃダメですか?

120 :115:03/09/12 08:13 ID:???
>>119
特定のpeerに対してのロードバランスなんですよ。
なのでBGP->OSPFのredistかなぁと。

121 :nobody:03/09/13 10:25 ID:???
>118

ああ、想定している状況が違うね。あとでゆっくり書きます

>120

その条件、結構難しいかも。特定のピアからのをredistするのは簡単だけど、
相手が事故って大量の経路を通知してきたらこっちのIGPが死んじゃうから、
prefix-filterも必要かも。max-prefixのリミットって今のIOSはちゃんと動
くんだっけ?

122 :眠たい質問者:04/06/06 00:02 ID:???
最近ルーティングのことを知り始めたのですが、下記の環境でルーティングをうまいこと
設定すればプロキシはいらなくなりますか?
いらなくなるのなら勉強してやってみるつもりです。

モデム(ルータ内蔵)
  |
Win2kServerPC(プロキシ稼働中、NIC2枚差し)
  |
LAN内の各クライアントPC


123 :122:04/06/06 08:35 ID:???
もしかしてこのスレ、誰も見てない?
最終投稿が03/09/13って・・・。
とりあえずageます。

124 :sage:04/06/06 12:34 ID:???
>>122-123
Win2Kがルータとして動いていると仮定して、ルータ内蔵モデムが
クライアントPCのあるネットワークをどうやって知ることが出来るのか
(ルーティングテーブルを持たせられるか)を考えてみましょう。
判らなかったら、初級ネット板逝きましょう。


125 :122:04/06/06 14:16 ID:???
>>124
Win2kはルータとしては動いてないです。
ルーティングとリモートアクセスってのをいじればできるのかな、と思ったけど
何が書いてあるのかさっぱりだったので結局止めたままです。

ルーティングを適切に設定すれば「クライアントPCからプロキシを経由しないでインターネットに出られる」ということですよね?
もう少し情報集めて勉強してみます。

126 :?:04/06/06 14:21 ID:???
懐かしいスレが上がっている、、、

>>125
クライアントを直接通信させるならモデムをPCのLANおけばいいだけでは
セキュリティ的な用件でプロキシにしてるんじゃないんですか?
何がやりたいのかよくわからないです

あと、ここは一応”インターネットルーティング"講座なんだけどね
nobody氏もここ半年ぐらい見てない気がするが


127 :beer:04/07/12 12:10 ID:C2tDCwUC
えらい人教えてください。
お気軽にポリシールーティングが出来るルータだかUNIX OSってありますか?
BA8000はお手軽そうですが、インターフェースが少なすぎる。
最低でも3つは必要です。
予算的には30万くらいです。

128 :AS7743:04/07/12 20:50 ID:wCooPIiF
どこまでの機能を求めているのかわかりませんが、ソース
ルーティング程度ならかなり多くの機器でできそうな気が
します。

PCルータでやるならLinuxのiproute2とか、
http://www.linux.or.jp/JF/JFdocs/Adv-Routing-HOWTO/lartc.iproute2.html
http://www.linuxgrill.com/iproute2-toc.html
FreeBSDのipfwとか、*BSDのpfとか。

Netscreen 25とかCat3550(EMI)でもできますが、ちょっと予算オーバーかな..。

129 : :04/07/13 21:45 ID:r0pkTiT9
>>128
http://bgp.potaroo.net/cgi-bin/as-report?as=AS7743

130 :anonymous@ i218-47-191-242.s02.a011.ap.plala.or.jp:04/12/15 02:26:41 ID:8wun9d0c
OSPFとEIGRPでどちらを利用するかで迷っています。
拠点数は3〜10の規模で、CISCO限定なのでEIGRPを
使うのがセオリーかと思ったのですが、OSPFと比較したとき
に何が優れているのか分からなくて困っています。
あえてOSPFではなくてEIGRPを使う場面というのは
どういう場面でしょうか。
EIGRPがマルチベンダで無い時点でかなり不利だと思うのですが。。。

ぼんやりとした質問で済みません。
よろしくおねがいします。

131 :?:04/12/15 08:07:24 ID:???
>>130
OSPFより収束が速い
単純な二重化構成ならOSPFより設計が簡単
メリットはこれぐらいかと

単純な二重化構成で拠点間がスポークならEIGRPがいいかも

三重化したり、単純二重化でなく低速バックアップ回線があったり、
拠点間をリング化したりするならEIGRPはやめた方がいいです


132 :anonymous@ i60-36-51-100.s02.a037.ap.plala.or.jp:04/12/16 00:21:03 ID:wRjE4Q+i
すみません。
1の資料っていまどこにあるのでしょうか。

133 :uho:04/12/16 21:26:32 ID:???
>>132
拡張子を pdf にして検索しる

134 :__:04/12/16 23:18:25 ID:???
>>133
さんくす
見つかりました。
インターネットウィークの資料は他にも面白そうな物が一杯ですね。
しっかり読ませてもらいます。

135 :anonymous@ eaoska196048.adsl.ppp.infoweb.ne.jp:2005/05/16(月) 16:32:56 ID:AZHGsw2l
すいませんが誰か教えてください。

1.あるIPデータグラムを転送するにあたって,ルーティング(L3)によって
処理するかアドレス解決(L2)によって処理するかは何を基準として
決定されるのですか?
2.ルーティングテーブルの持つエントリ数が非常に大きくなった場合,
どのような問題が生ずると考えられるのですか?
 2に関しては通信速度が遅くなる、レスポンス低下でいいのかなと
思うのですが、1は調べましたが分からないです。


136 :syscow:2005/05/16(月) 23:42:19 ID:???
>>135
どんなIPデータグラムも、まずL3の経路表を参照して、それからL2で
アドレス解決して転送するよ。ルータならね。


137 :anonymous:2005/05/17(火) 01:28:51 ID:???
>>136
普通はそうして経路表を参照した後、結果をキャッシュ(転送表)に入れとき、続けて
同じアドレスに送られるパケットが着たらそのキャッシュを参照してnext hopに送る。
この表をさらにハードに送って高速化なんかもされる。

>>135
2. の他の問題はメモリを食うことと、経路情報の変動に対処するのに要する負荷の増大。

138 :136:2005/05/17(火) 07:42:08 ID:???
>>137
ふむ、そうした高速化って普通というほど普通じゃないと思うんだけど
どこの実装のこと?

古きゆかしきBSD由来の実装はL3の経路表の中にL2の情報を入れちゃってるし、
CiscoのCEFは結局L3の経路表とL2のアドレス解決情報を分離したまま高速化
しただけだし、こいつらは当てはまらないよね。いわゆる forwarding cache
は結局L3のキャッシュだし。


139 :anonymous:2005/05/17(火) 09:36:47 ID:???
>>138
あれ、CiscoのFIBってL2は含まないのですか?それは知りませんでした。 そうだと
思い切ってた。 自分が某メーカでいじってた実装ではL2も含めてキャッシュしてたもんで
そういうもんだと思ってました。 

140 :anonymous:2005/05/17(火) 10:57:46 ID:???
>>139
138が無知なだけなんだけど、誤解が広がるのは良くないので
http://www.cisco.com/japanese/warp/public/3/jp/product/hs/ios/cef_wp.shtml


141 :138:2005/05/17(火) 11:09:24 ID:???
>>140
FIB (L3) と Adjacency Table (L2)は明確に分離されているように見えるが...


142 :135:2005/05/17(火) 13:03:34 ID:sBxf7s6g
>>136,137
ありがとうございます!!助かりました

143 :_:2005/05/17(火) 16:46:54 ID:???
>>135
素人が作ったようなへたな問題なんで問題自体が正確じゃないが、
気持ちだけを汲み取ってやると、問題は

 ルーティング処理 → 宛先が異なるネットワークアドレスの場合
 ARP解決 → 宛先が同一ネットワークアドレスの場合

という部分の処理の違いを問いたかったんじゃないかな。

あくまで出題者の気持ちを汲み取って深読みしただけだから
本当かどうかはわからないけどな。

144 :139:2005/05/18(水) 04:58:31 ID:???
>>141
>>140さんのリンク先の図では2つのテーブルが別にありますが、それが←→という線で
繋がってますよね。 どちらのテーブルもIPアドレスで参照されるので、FIBが参照された後、
その次に参照したL2の結果をFIBのエントリーにキャッシュすると言うのはごく真っ当で
単純な最適化かと思います。 まあこれが実際に1つの表として実装されるかポインタで
参照される2つの表かというのは似たようなものかと。 



145 :anonymous@ zaq3dc06822.zaq.ne.jp:2005/06/13(月) 15:04:49 ID:???
age

146 :anonymous:2005/06/13(月) 15:07:24 ID:???
sage

147 :さんぷるこんふぃぐどう?:2005/06/14(火) 00:39:16 ID:???
あどれすふぁみりー あいぴーぶいふぉ 
ねいばー い てっん よ し りもーとーえす まん こ
のー おーとさまり
のー しんくろないぜいしょん
いくじりすぎっとーあどれすふぁみりー


148 :anonymous@ ZF011066.ppp.dion.ne.jp:2005/11/02(水) 17:23:28 ID:???
WindowsXPで2枚挿しているNICの片側のデフォルトルート(0.0.0.0)を故あって
永遠に削除したいので、コマンドプロンプトからroute delete 〜〜を入力しました。

しかし再起動したら復活しやがったので、今度はコマンドに -p をつけたのですが
再起動するとやっぱり復活しやがります。

こんな私はスタートアップフォルダにroute delete 〜〜を記述したバッチファイルの
ショートカットをぶち込んで渋々対応しなければならないのでしょうか?

149 : :2005/11/02(水) 20:54:12 ID:???
>>148
「インターネットプロトコル(TCP/IP)のプロパティ」 のところにデフォルトゲートウェイ書いてない?
そこがカラなら大丈夫だと思うんだけど。

2 枚 NIC 挿しててもデフォルトゲートウェイは 1 つしか使われないから Metric 増やして対処してもいいかもね。

150 :hoge:2006/06/08(木) 00:19:50 ID:Ceo+ez2M
>>131
> 三重化したり、単純二重化でなく低速バックアップ回線があったり、
> 拠点間をリング化したりするならEIGRPはやめた方がいいです
ごめん、色々考えてみたけど理由が思い当たらない。
何でか教えてください…orz

151 :hoge:2006/06/08(木) 00:29:36 ID:???
すっげぇ古いスレだった…正直スマンカッタ。

152 :hoge:2006/06/08(木) 00:52:37 ID:???
://www.n-study.com/kyo/archives/2005/01/eigrp_1.html
ここに答えが書いてあった。

153 :anonymous@ global111.kinet-tv.ne.jp:2006/06/09(金) 04:52:17 ID:???
先日からデータセンターを借りてルーティングの作業をしているのですが、
一向に進みません・・・ orz
会社の方からは ***.***.1.10/30 と***.***.2.0/29 というIPを
もらいました。デフォルトゲートウェイは ***.***.1.9 にしろ、
といわれています。
以上の状況で、スイッチを試行錯誤弄ったのですが、
上手くIPを振り分けられません。
ルータ - スイッチ - サーバ というシンプルな構成で
サーバーを10台ほど設置してそれぞれに固定IPを振り分けたいという状況です。

ルータもスイッチも介さずに直接サーバーに接続したところ、
サーバーのIPを***.***.1.10にしたところ、
外部から該当IPに対してアクセスが可能になったものの、
***.***.1.11 や ***.***.2.1などにしてもアクセスできません。
これはなぜでしょうか?
元のルータでIP割り振りの設定をしているのであればアクセスできるはずではないんでしょうか?
ネットマスクは 255.255.255.0 や 255.255.0.0 で試しましたが、ともに無理でした。


この設定にはルータが必要になるのでしょうか?
(現在はレイヤー2スイッチしかない状態です)
スイッチで色々IPも割り振って試してみましたが、無理でした。
どなたかお助けを・・・

154 :nanasi:2006/06/09(金) 06:06:17 ID:???
>>153
このスレは、どちらかというとデータセンター側の機材で行うルーティングに関する
話題を扱うところなのでスレ違いですよ。

作業にあたって前提とされる知識が足りていない様なので、
がんがってください。

実は、サーバと呼ばれている物の中にファイアウォールやロードバランサー
が混じっていたりしませんか?



155 :anonymous@ softbank219000146031.bbtec.net:2006/06/11(日) 07:48:51 ID:???
ヒント:http://jump.sagasu.in/goto/funny/



156 :__:2006/06/19(月) 01:09:40 ID:???
>>153
あんさんのスキルでは無理。
ギブアップして専門家に依頼しなさい。

157 :anonymous@FLH9Aac005.fks.mesh.ad.jp:2007/10/29(月) 23:29:16 ID:jp1zQYfY
低レベルな質問で申し訳ございません。
バッファローのルーターでルーティングできますか?
その場合は、3台必要ですか?
以前2台で失敗しました。

158 :anonymous@host5-46.net.fenics.or.jp:2007/12/28(金) 16:36:33 ID:uyShdz4p
OSPFのDRがダウンしてBDRがDRに変わるとき通信断ってでる?
でるとしたらどのくらい?

159 :出直してください:2007/12/28(金) 20:58:37 ID:0Rq3u+pL
装置による

160 :anonymous@KD114017184107.ppp-bb.dion.ne.jp:2009/01/16(金) 00:29:58 ID:???
>1 の資料、わかりやすくて実用的ですげぇ
使わせてもらうわ thx

161 :anonymous:2009/10/05(月) 21:07:09 ID:???
出てこいやおい

162 :NE:2009/10/24(土) 19:33:16 ID:???
少しのネットワークSE経験があるのですが、ISP運用に転職できますか?
ダメならどんなルーティング知識が必要ですか?

163 :age:2009/10/25(日) 11:57:32 ID:???
すんません
下の絵のospf NWの質問です、

R1--R2
| /
| /
R3

R1 loopback:ara10
R2 loopback:ara10
R3 loopback:ara10
R1-R2 :area0
R1-R3 :area10
R2-R3 :area10

R2のloopback宛経路ですが、
R1のDBをみたらarea 0のIFではsummary LSAとしてもらってます。
area10のIFではrouter LSAとしてもらってます。
R3のDBをみたらrouter LSAとしもらってますが
summary LSAとしてはもらってません。

ここでR2-R3のリンクが切れたとき、R3上で一瞬経路がなくなりますが
R1はsummary LSAをR3にupdateし、めでたくR3で経路が復旧します。

ただ、はなっからR1はR2loopback宛のsummary LSAをR3に投げておけば
もらっておけば、経路切り替えも瞬時で行われると思っているのですが
渡さないのはABRとしてのRFCの仕様になるんですかね?


164 :anonymous@05004016256307_vs:2009/11/14(土) 02:18:50 ID:LUo+qCE3
はなっから投げてればって
投げてるよ

165 :anonymous@05004016256307_vs:2009/11/14(土) 02:21:38 ID:LUo+qCE3
糞スレ
初心者質問スレ

うんこ

50 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)